Backup up Files and Folders

Applies to: Standard, Professional and Server Editions of Macrium Reflect only.

 

Overview

A file and folder backup is a useful way to backup your working files, personal files, and any precious data. Unlike many other backup solutions Macrium Reflect can even backup open or locked files by using Microsoft Volume Shadow copy Service (VSS).

Using the procedure presented here, you can either run a backup immediately or create a backup definition file and schedule the backup.

To create a backup of your files and folders

  1. Click on the Create File and Folder link as shown below:

  2. Click Add folder.


     

  3. Select a folder and click OK,

  4. This will present the 'Select folder to backup' dialog



    You can now specify the file types you wish to include or exclude from the backup process.

  5.  

    Action

    Description

    Include subfolders

    You may choose to include all subfolders within the chosen directory

    File Inclusion Mask

    You can include all or just some of the files. In this example, '*.*' has been selected but you could choose say *.doc files.

    File Exclusion Mask

    Use the File Exclusion Mask to outline the files you do not wish to backup.

    Folder Exclusion Mask

    Add folder names to the Folder Exclusion Mask as required. These folders will not be added to the backup image. Names should be semicolon ';' delimited.

    Exclude hidden files and folders

    As described

    Exclude System files and folders

    As described

     

    Include or exclude files and folders by typing in the File Inclusion Mask, File Exclusion Mask and Folder Exclusion Mask edit boxes.
    The most common way to select a type of file is to use a wildcard search with a file extension. For example: *.doc; *.docx; *.docm.

    Where:

    Note: In Windows, file extensions are hidden by default. To show file extensions: Open Windows Explorer and click Organize > Folders and Search Options (in Windows XP Tools > Folder Options).  On the View tab, clear the checkbox beside Hide extensions for known file types.

     

    You can include or exclude files by their filename or file extensions as follows:
     

    Example

    Meaning

    *.doc; *.docx; *.docm

    All Microsoft Word files

    20100912 AC.doc

    The file named: 20100912 AC.doc

    abc.xls; *.jpg

    file: abc.xls and all .jpg files

    *.jpg; *.png; *.gif

    Common graphic file formats

    *.*

    All files

    *.pst

    All Outlook email files

     

    Hidden files and folders are included by default, to exclude them select Exclude hidden files and folders.
    To exclude operating system files and folders, select Exclude system files and folders.

    Tip Including hidden files and folders is useful for backing up hidden folders such as the folder used to hold Microsoft Outlook email. The Outlook folder is hidden by default. To show hidden folders in Windows: Open Windows Explorer and click Organize > Folders and Search Options (in Windows XP Tools > Folder Options).  On the View tab, select Show hidden files folders.

     
  6. Click OK to return to the 'File and Folder Backup' dialog. Note the folder just selected is now present in the list. You can add as many folders as you wish by repeating from step 2 to 5.

  7. Choose a backup destination from the options available, either:

    - Select Folder and browse for a folder by clicking the browse  button.

    OR

    - Select CD/DVD Burner and place a blank disk in the drive.

  8. Click Alternative Locations to specify a list of possible target folders.

  9. We recommend that you leave the filename as the image name. However, if you would prefer a different filename, deselect Use the Image ID as the filename, and type a name in the Backup filename box.

  10. Click Next.

    The File and folder backup Backup Summary screen appears.
    To change settings such as disk space management, email notification, password protection, encryption, compression, image splitting, and image verification, click Advanced Options.

  11. Click Finish.

    If you have chosen CD/DVD burner you are prompted to insert a disk.

    The Backup Save Options dialog appears.

  12. To run this backup immediately, select Run this backup now.

  13. To save this backup as a backup definition file, select Save this backup as an XML Backup Definition File and type a name in the filename box.

    Once saved, the definition appears in the Macrium Reflect main window on the Backup Definition Files tab. You can use the backup definition file to re-run the full backup, run the backup in incremental or differential mode, or schedule the backup.

  14. We recommend that you accept the default folder. However, if you want to select a different folder, click the browse button.

  15. Click OK.

    If you selected Run this backup now, the backup runs while the Create Backup Wizard dialog displays the progress.

  16. If required, adjust the priority of the backup task compared with other windows processes by dragging the slider.

  17. When backup is complete click OK.

When the backup task is complete you can view the log in the Log tab of the Macrium Reflect main window.